Nexus Release tomorrow morning Sept 18 at 7 am CDT

Scheduled for Sep 18, 07:00 - 07:30 CDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 17, 2026 - 10:58 CDT

Scheduled

Maintenance window to release support for TESTING Interleague tournaments with a few other items being released as well.
Posted Sep 17, 2026 - 10:57 CDT
This scheduled maintenance affects: Franchise Services (Nexus, Resource Library) and Member Services (Pool League), Accounts/Join.