Schedule Edits Not Working Properly in Nexus

Incident Report for Poolplayers

Resolved

We are not able to replicate the schedule issues from this weekend. Please edit schedules as needed and report any issues to nexus@poolplayers.com. Thank you.
Posted Jun 29, 2026 - 09:47 CDT

Investigating

We are aware that schedule edits in Nexus are not working properly at this time. We ask that you hold off making any schedule changes, if possible, until we get this corrected.

If you have any time sensitive schedule changes that must be made today for League play today, Sunday 6/28/26, please contact the Nexus After Hours Emergency Hotline at 636-625-8611 ext. 5410. All other requests should be sent to nexus@poolplayers.com and a Support Services Team Member will assist you when the office opens again tomorrow.
Posted Jun 28, 2026 - 12:44 CDT
This incident affected: Franchise Services (Nexus).