SK App down - 3/1/2026

Incident Report for Poolplayers

Postmortem

On March 1, from 7:52 PM to 8:02 PM Central Time (CT), the network experienced intermittent service interruptions across consumer-facing applications, including interruptions to Scorekeeper’s ability to keep score.

The incident was caused by database lock contention on scoring-critical records during concurrent write traffic. As contention increased, request queues grew and database connection capacity was exhausted, resulting in broad service degradation.

Engineering, Support, and DBA teams responded quickly, identified the blocking session chain, and terminated long-running blockers. Customer-visible impact ended at 8:02 PM CT, Support confirmed recovery at approximately 8:11 PM CT, and full backend stabilization was completed by 9:15 PM CT.

We are first putting added safeguards in place, starting with a monitored circuit breaker, and fixing the specific requests that triggered the slowdown to reduce the chance of this happening again.

Posted Mar 02, 2026 - 16:28 CST

Resolved

This incident has been resolved.
Posted Mar 01, 2026 - 20:16 CST

Update

The SK app is up and running again!! Have a great evening.
Posted Mar 01, 2026 - 20:11 CST

Investigating

The SK app is currently down. The Tech Team is looking into the cause at this time. We will update you are things progress. We apologize for the inconvenience.
Posted Mar 01, 2026 - 20:02 CST
This incident affected: Scorekeeper.