Master Divisions Input: Unable to input Masters matches
Incident Report for Poolplayers
Resolved
This incident has been resolved.
Posted Jun 18, 2024 - 16:40 CDT
Investigating
Master Divisions Input: Unable to input Masters matches.

We are investigating the problem with not being to complete input for Master Divisions.
Posted Jun 18, 2024 - 15:56 CDT
This incident affected: Franchise Services (Nexus).