Error When Accessing HL's in Nexus - This issue also effects Tournaments with a specific HL assigned to the tournament

Incident Report for Poolplayers

Resolved

The Tech Team ate their Wheaties this morning! This issue has been resolved. Have a great weekend!
Posted Mar 20, 2026 - 11:31 CDT

Investigating

We have identified that there is an issue with opening/accessing HL's in Nexus. This issue does effect any Tournament that has a specific HL assigned for that event. The Tech Team is aware and a ticket has been created to fix this issue. We apologize for any inconvenience.
Posted Mar 20, 2026 - 11:13 CDT
This incident affected: Franchise Services (Nexus).