Previous Qualifications & Details Showing in MS

Incident Report for Poolplayers

Resolved

This incident has been resolved.
Posted Aug 20, 2026 - 13:48 CDT

Investigating

We are aware that previous qualifications and details are showing on MS and causing some confusions/questions. Qualifications on MS should be limited to future qualifications. The Tech Team is working diligently to get this corrected as soon as possible. We will update you as soon as this is corrected. We apologize for any inconvenience.
Posted Aug 20, 2026 - 12:08 CDT
This incident affected: Member Services (Pool League).