Player LA's Not Holding in Nexus After Preview/Print

Incident Report for Poolplayers

Resolved

This issue has been resolved. Have a great weekend!
Posted Sep 18, 2026 - 15:07 CDT

Identified

It has been brought to our attention that LA's are not sticking after being raised or lowered in Nexus after preview/print. The Tech Team is actively working on a fix and we hope to have it released soon. We sincerely apologize for the inconvenience. Stay tuned for updates!
Posted Sep 18, 2026 - 13:17 CDT
This incident affected: Franchise Services (Nexus).