Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 30, 2026 - 16:15 CDT
Scheduled
New Scorekeeper & Member Services Update Process: Gradual Rollouts for Stability
APA Tech has started slower, safer rollouts for Scorekeeper and Member Services updates. Updates will now be released gradually over several days or up to a week instead of all at once.
Why?
This allows us to catch and fix issues early, minimizing disruptions and ensuring a more stable, reliable experience for all users and league nights.
We take the experience of our players and League Operators seriously and want to ensure smoother sailing moving forward.
Tomorrow:
The new Member Services App rollout begins.
Key Highlight: ✅ Multi-Language Support is here!
The app now fully supports:
Spanish Canadian French Japanese Simplified Chinese
Players and operators in the U.S., Canada, Japan, and beyond can now view standings, stats, schedules, scoresheets, and league info in their preferred language. Bug Fixes:
Improved messaging for unpaid users trying to access stats, membership card, or profile pages (these features remain unavailable until payment is current).
Posted Mar 30, 2026 - 16:02 CDT
This scheduled maintenance affected: Member Services (Pool League).