Franchise Email Is Down

Incident Report for Poolplayers

Resolved

This incident has been resolved.
Posted May 06, 2026 - 16:23 CDT

Monitoring

Due to power outages in the St. Louis area, our headquarters has been running on battery backup, and our batteries have run out of juice. The franchise email system is being shut down and will be turned back on once power has been restored.

Unrelated to email, the FTP site will also be unavailable until power is restored.
Posted May 06, 2026 - 14:39 CDT
This incident affected: Franchise Services (Email).