Division Review: receiving the "whoops" error when trying to go into division review.
Incident Report for Poolplayers
Resolved
This incident has been resolved. Division review is back up and running.
Posted Nov 11, 2024 - 14:28 CST
Investigating
We are currently investigating this issue.
Posted Nov 11, 2024 - 13:42 CST
This incident affected: Franchise Services (Nexus).