Multiple Log Outs in SK

Incident Report for Poolplayers

Resolved

This incident has been resolved.
Posted Aug 01, 2025 - 10:21 CDT

Investigating

It has been brought to our attention that many have been made to log in multiple times to the SK app during use. The Tech Team is looking into this issue. We will update when we know more. Again, we apologize for the inconvenience.
Posted Jul 30, 2025 - 10:09 CDT
This incident affected: Scorekeeper.