NMS APP Issues: 1) MVP link on the dashboard not working (work around: navigate through the division) 2) Lifetime Stats not loading on the dashboard

Incident Report for Poolplayers

Update

MVP stats showing "league not found" is fixed on league.poolplayer.com. Still working on the fix for the app.
Posted Jul 30, 2026 - 17:41 CDT

Update

We are continuing to investigate this issue.
Posted Jul 30, 2026 - 17:11 CDT

Investigating

We are currently investigating this issue.
Posted Jul 30, 2026 - 16:18 CDT
This incident affects: Member Services (Pool League).