SK Congestion/Lagging/505 Gateway Errors/DOWN

Incident Report for Poolplayers

Resolved

This incident has been resolved.
Posted Mar 09, 2026 - 21:15 CDT

Monitoring

We are seeing traffic return to normal. Some may have matches that are hung up. If that is the case, you will need to reset those matches if they do not work themselves out organically.
Posted Mar 09, 2026 - 20:50 CDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 09, 2026 - 20:27 CDT

Update

Things are moving, but performance is still lacking. The Tech Team is diligently working to address. We don't have an ETA at this time.
Posted Mar 09, 2026 - 20:13 CDT

Identified

The Tech Team believes they have identified the issues. You should see performance improvement soon.
Posted Mar 09, 2026 - 19:52 CDT

Investigating

We have been made aware that some are experiencing lagging issues and 505 Gateway Errors in the SK app. The Tech Team has been made aware and they are looking into it.
Posted Mar 09, 2026 - 19:34 CDT
This incident affected: Scorekeeper.