SK App Down

Incident Report for Poolplayers

Postmortem

I’ll keep this brief, as the outage was short and had a simple cause.

We’ve been investing in automated monitors to alert us when performance issues begin to develop. The goal is to catch problems well before they impact league night. Last night, we were testing one of these monitors, and it did not handle SK traffic well.

As reports came in, the person working on the monitor quickly noticed the correlation and disabled it. Performance returned to normal immediately.

This monitor had been tested in other environments for several days without issue. However, the scale of SK traffic exposed a performance impact that did not appear elsewhere.

We’ll continue improving our testing approach to better account for production-level traffic before rolling out changes like this.

Posted Apr 07, 2026 - 14:46 CDT

Resolved

This incident has been resolved. We appreciate your patience. Have a good evening!
Posted Apr 06, 2026 - 19:08 CDT

Update

We are continuing to monitor for any further issues.
Posted Apr 06, 2026 - 18:55 CDT

Monitoring

The system has recovered and we see that app traffic has stabilized. We will continue to monitor. We apologize for the inconvenience.
Posted Apr 06, 2026 - 18:53 CDT

Investigating

We are aware that the SK App is down. The Tech Team is investigating now.
Posted Apr 06, 2026 - 18:47 CDT
This incident affected: Scorekeeper.