Players Incorrectly Identified as Suspended in Nexus

Incident Report for Poolplayers

Resolved

Tech Team to the rescue! This issue has been resolved.
Posted Jun 22, 2026 - 16:57 CDT

Identified

We are aware that previously suspended players may be showing currently suspended in Nexus. The Tech Team is working to get this corrected as quickly as possible. We apologize for any confusion or frustration this may cause. We will update this page as soon as it is corrected.
Posted Jun 22, 2026 - 16:37 CDT
This incident affected: Franchise Services (Nexus).