Issues with removing players from roster when setting up Fall divisions

Incident Report for Poolplayers

Resolved

This incident has been resolved.
Posted Aug 20, 2026 - 16:32 CDT

Investigating

We are aware of an issue where removing inactive players from inactive divisions - when setting up for Fall - is not working... we are looking into this now and hope to have a fix out shortly
Posted Aug 20, 2026 - 15:14 CDT
This incident affected: Franchise Services (Nexus).